OpenZFS 2.1.5 发布,兼容 Linux 5.18、修复错误

OpenZFS 2.1.5 已发布,这是开源 ZFS 文件系统实现的最新版本,与现代 Linux 和 FreeBSD 系统兼容。
新版本主要是修复错误,此外还包括面向 Linux 5.18 的兼容性

OpenZFS 2.1.5 已发布,这是开源 ZFS 文件系统实现的最新版本,与现代 Linux 和 FreeBSD 系统兼容。

新版本主要是修复错误,此外还包括面向 Linux 5.18 的兼容性更新,这意味着 OpenZFS 已官方支持最新的稳定版 Linux 内核,同时也保留对 Linux 3.10 的支持。

OpenZFS 2.1.5 还包含针对 Linux 5.19 兼容性的补丁,不过这些补丁仍处于发布候选阶段,因此在下个月稳定发布之前仍可能出现破坏性变更。但无论如何,这至少说明 OpenZFS 已经开始测试下一个内核版本。

至于 FreeBSD,目前兼容 FreeBSD 12.2-RELEASE 以及更新的版本。

总结如下:

  • Linux:兼容 3.10 – 5.18 内核
  • FreeBSD:兼容自 12.2-RELEASE 以来的系统

OpenZFS 2.1.5 其他变化

  • 优化 sorted scan memory accounting
  • 针对 RHEL 的变更
  • 在 FreeBSD 上实现对 hole-punching 的支持
  • 删除 dracut 的 zfs-load-module.service 安装
  • ……

详情查看 release note。

延伸阅读

  • OpenZFS 3.0 有望支持 macOS 和 DirectIO,继续优化 Window 版本

关于作者: qwephp

.

为您推荐